Home Cisco Cisco: Cisco router as NAT device using COMCAST cable modem

Cisco: Cisco router as NAT device using COMCAST cable modem

by Kliment Andreev
0 comment
Reading Time: < 1 minute

I bought an used Cisco 2611 router from eBay to use it on my internal network. While I was playing with it, I decided to try and see if I can get it working as a NAT device instead of my current FreeBSD box. You will still need the modem that your ISP provides it to you. I doubt that you can use a coax Cisco module and replace the ISP’s modem. Comcast uses modem’s MAC address to track your connection, usage etc…

So I have two NICs in the router and this is how they are confugured.

interface Ethernet0/0
description OUTSIDE
ip address dhcp   #The outside interface gets its IP address from the modem since I don;t have a static IP
 
no ip unreachables
no ip proxy-arp
ip nat outside  # Define the NAT
 
half-duplex  # For some reason, if I used auto or full-duplex, the connection was painfully slow
 
no cdp enable  # You don’t need Cisco CDP protocol running on the outside interface
!
interface Ethernet0/1
description INSIDE
ip address 192.168.1.1 255.255.255.0 # My internal IP, this is going to be your gateway IP
 
no ip proxy-arp
ip nat inside # Define the NAT on the inside interface
 
full-duplex
!
 
ip nat inside source list 1 interface Ethernet0/0 overload
ip classless
no ip http server
ip pim bidir-enable
!
access-list 1 permit 192.168.1.0 0.0.0.255

Last line defines the access list. It means that all hosts in 192.168.1.0/24 range will be alowed to use the NAT. The subnet mask needs to go in reverse, so 255.0.0.0 is 0.0.0.255.

0 comment
0

Related Articles

Leave a Comment

This website uses cookies to improve your experience. We'll assume you're ok with this, but you can opt-out if you wish. Accept Read More